Welcome, Guest. Please login or register.
September 02, 2014, 07:52:50 PM
Home Help Search Login Register
News: Welcome to CISinks.com forum!
Continuous Ink System       Refillable Cartridge       Bulk Refill Ink       For EPSON       For HP       For Canon       For Brother      
+  CISinks.com Forum for Continuous ink system, refillable ink cartridges and bulk refill ink for EPSON, HP, Canon and Brother Inkjet printers
|-+  Troubleshooting and Installation Instructions
| |-+  Epson Printers
| | |-+  NX420 CISS Cartridge not recognized, replace ink cartridge
« previous next »
Pages: [1] Print
Author Topic: NX420 CISS Cartridge not recognized, replace ink cartridge  (Read 2787 times)

mauiflower
New Member
*
Posts: 3


« on: October 03, 2012, 03:53:41 PM »

System was working fine since I got it. Now, I always get the "cartridge not recognized" message, followed by replace c ink cartridge. I have removed cartridges, cleaned contacts, put them back, shut off the printer, unplugged the usb ink, can't get the message to go away. Running driver version 9.0 I don't think I did a firmware update. Please help!
Logged

Continuous Ink System    Refillable Cartridge    Bulk Refill Ink    For EPSON    For HP    For Canon    For Brother   
cisinks
Administrator
Hero Member
*****
Posts: 289


« Reply #1 on: October 05, 2012, 08:03:07 PM »

Hello,

I have seen this happen before. What you should do is remove the chips that are in the blue box on the CISS that pertains to the CYAN cartridge and clean out the chip with alcohol and a wipe. I would also suggest you check and see if all of the cartridges are locking properly into place.

If you need assistance, please give us a call (626) 575 0860

-CISinks
Logged
mauiflower
New Member
*
Posts: 3


« Reply #2 on: October 29, 2012, 04:45:05 AM »

Well, it worked for a while after resetting the blue chip box a BUNCH of times... Now, I have run into problems AGAIN. Cycles through the error messages of "replace cartridges", "cartridges not recognized", forgot the exact wording regarding "non Epson cartridges detected, continue anyways", on and on. I was thinking of maybe changing all of the chip sets in the blue box. I still have a bunch of old empty OEM cartridges I could take the chips out of. I was wondering if maybe there was damage to the flat wire set? I really need to get the printer working. When it works it's great, but when it doesn't it's a real pain. Thanks for your continued help. :-)
Logged
mauiflower
New Member
*
Posts: 3


« Reply #3 on: October 29, 2012, 02:23:00 PM »

Update: Today I changed the chip sets with some used ink carts I had. Still does not work.
Logged
cisinks
Administrator
Hero Member
*****
Posts: 289


« Reply #4 on: November 07, 2012, 05:36:55 PM »

The only thing I can see going on with the system would be that somehow the blue box isn't properly communicating with the chips on the cartridges.

If you take a look at the chips on the cartridges, is there any noticeable scratches? Maybe even a crack? The last time I encountered this problem, it was a cracked chip.

Should you find a crack, e-mail me a picture.

sales@cisinks.com Thanks!

-CISinks
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by SMF 1.1.16 | SMF © 2011, Simple Machines