Welcome, Guest. Please login or register.
September 19, 2014, 09:56:22 PM
Home Help Search Login Register
News: Welcome to CISinks.com forum!
Continuous Ink System       Refillable Cartridge       Bulk Refill Ink       For EPSON       For HP       For Canon       For Brother      
+  CISinks.com Forum for Continuous ink system, refillable ink cartridges and bulk refill ink for EPSON, HP, Canon and Brother Inkjet printers
|-+  Troubleshooting and Installation Instructions
| |-+  Canon Printers
| | |-+  mg5420 problems
« previous next »
Pages: [1] Print
Author Topic: mg5420 problems  (Read 327 times)

shotgun_lobotomy
New Member
*
Posts: 3


« on: March 10, 2014, 08:10:07 PM »

i put one of ur ciss on my canon printer, first day it worked great, but now it wont print blue, if i do a cleaning it starts too but by the time it gets to the bottom its gone. i print tons a day so this is a real problem for me. i have tried a million cleanings and primed it and everything and still the same problemsi have noticed that its the only tank on the resevoir that doesnt seemed to have used any ink. im lost HELP! lol
Logged

Continuous Ink System    Refillable Cartridge    Bulk Refill Ink    For EPSON    For HP    For Canon    For Brother   
cisinks
Administrator
Hero Member
*****
Posts: 293


« Reply #1 on: March 11, 2014, 03:38:17 PM »

Hello,

I was wondering if you have already installed the air filters? If it was printing right at first and then stopped printing for you, then it could indicate that the air filters have not been installed.

Also, make sure to install the rubber washers that come included in the package, these are there to create an extra seal between the cartridges and the print head.

Check this video out and follow the steps  from here as well.

http://www.youtube.com/watch?v=2ccxMBaSUQI
Logged
shotgun_lobotomy
New Member
*
Posts: 3


« Reply #2 on: March 11, 2014, 04:30:23 PM »

yeah i installed the air filters and washers , ive primed from the tank end and everything seems to be going good, but i do notice a little bit of ink pooling under the cartrage when i pull it out

*i ment thr primeing goes good, the printing is still the same
« Last Edit: March 11, 2014, 04:59:32 PM by shotgun_lobotomy » Logged
shotgun_lobotomy
New Member
*
Posts: 3


« Reply #3 on: March 11, 2014, 05:43:03 PM »

ok that meathod in the video seemed to work .. ill be back if not Smiley
Logged
cisinks
Administrator
Hero Member
*****
Posts: 293


« Reply #4 on: June 24, 2014, 07:39:30 PM »

Hello,

Okay sounds good. If you have any questions we'll be here.


-CISINKS
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by SMF 1.1.16 | SMF © 2011, Simple Machines